IXwebhosting支持SQLITE3,php版本修改为5.3.x或者5.4.x的方法

ixwebhosting不支持SQLITE3数据库的主要原因是php version问题, sqlite 3支持在5.3.x以上的版本,ix 默认5.2.x支持sqlite 2。 现在主要是解决php版本问题。

win空间php版本修改为5.3.x或者5.4.x的方法步骤

1. 登陆ix账户后台,点击manage

2. 选择web options

3. 选择相应的域名进入 然后点击php下面的edit

4.选择php 5.3.x以上的版本

linux空间php版本修改步骤:

win空间和linux空间后台略微有点差别,步骤三有的空间类似,相信大家摸索一下即可搞定

更新步骤三 linux系统:

应该会有php 高级选项,关闭默认php,开启高级选项,里面添加php53。 等待几分钟,php版本就是5.3的了。

提交然后点击上面的apply

7

完事用<?php  phpinfo(); 测试一下,就ok了。

更新20130427,对于linux cp8 等控制面板:

首先:在网站根目录下的cgi-bin目录里添加一个文件 php53.cgi , 并且确保此文件的权限为755,文件内容为:      

  1. #!/bin/sh
  2. export PHP_FCGI_CHILDREN=3
  3. exec /hsphere/shared/php53/bin/php-cgi

然后:
在网站的.htaccess文件里添加addhandler,代码如下:

  1. AddHandler php53  .php
  2. Action php53 /cgi-bin/php53.cgi

ix客服的部分回复:

PS: 有的少数IX空间是cp8面板,没有advance按钮,客服回答处理方法:
Dmitriy Morozov: Setting PHP 5.3 on your control panel could be retrieved in another way.
Dmitriy Morozov: Please create .htaccess file under your domain folder with next contents:
Dmitriy Morozov: AddHandler php53 .php
Dmitriy Morozov: Action php53 /cgi-bin/php53.cgi
Dmitriy Morozov: Then please go to cgi-bin folder and create php53.cgi file with such contents:
Dmitriy Morozov: #!/bin/sh
Dmitriy Morozov: export PHP_FCGI_CHILDREN=3
Dmitriy Morozov: exec /hsphere/shared/php53/bin/php-cgi
Dmitriy Morozov: Then please set 755 permissions for php53.cgi file.
Dmitriy Morozov: Sorry for confusion. This is the process.
Dmitriy Morozov: It is for Cp8 and higher.
Dmitriy Morozov: Control panel cp7 has another process as described above.

最后一招你实在搞不定,也可以让在线客服给你搞,很快额

另附Hostgator虚拟主机修改php版本方法:

目前默认的php version都是5.2.x,通过跟2家提供商的客服聊天,终于知道如何让网站php变身5.3.x,亲测成功:

Hostgator(linux):
解决方法来自: http://support.hostgator.com/art … re-software/php-5-3
非常简单:  在网站的.htaccess文件里添加

  1. # Use PHP 5.3
  2. AddType application/x-httpd-php53 .php

发表评论